]> www.ginac.de Git - ginac.git/blobdiff - check/Makefile.am
- Completely restructured the checks in subdir check/.
[ginac.git] / check / Makefile.am
index 87976d8f26bab0983b95e311eadee860cd32d1ee..96ec4089f6b64111f6060fec582850b47742223b 100644 (file)
@@ -1,12 +1,17 @@
 ## Process this file with automake to produce Makefile.in
-TESTS = run_checks
-check_PROGRAMS = check_ginac
-check_ginac_SOURCES = paranoia_check.cpp numeric_output.cpp \
-  numeric_consist.cpp powerlaws.cpp expand_subs.cpp inifcns_consist.cpp \
-  differentiation.cpp poly_gcd.cpp normalization.cpp matrix_checks.cpp \
-  linear_solve.cpp series_expansion.cpp lortensor_check.cpp \
-  fcntimer.cpp main.cpp check.h
-check_ginac_LDADD = ../ginac/libginac.la
+TESTS = run_exams run_checks run_times
+check_PROGRAMS = exams checks times
+exams_SOURCES = exam_paranoia.cpp exam_numeric.cpp exam_powerlaws.cpp \
+  exam_differentiation.cpp exam_polygcd.cpp exam_normalization.cpp \
+  exam_pseries.cpp exam_matrices.cpp exam_lsolve.cpp exam_noncommut.cpp \
+  exam_misc.cpp exams.cpp exams.h
+exams_LDADD = ../ginac/libginac.la
+checks_SOURCES =  check_numeric.cpp check_inifcns.cpp check_matrices.cpp \
+  check_lsolve.cpp genex.cpp checks.cpp checks.h
+checks_LDADD = ../ginac/libginac.la
+times_SOURCES = time_dennyfliegner.cpp time_gammaseries.cpp timer.cpp \
+  times.cpp times.h
+times_LDADD = ../ginac/libginac.la
 INCLUDES = -I$(srcdir)/../ginac
-CLEANFILES = result.out
-EXTRA_DIST = result.ref run_checks
+CLEANFILES = exams.out checks.out times.out
+EXTRA_DIST = exams.ref checks.ref times.ref run_exams run_checks run_times