]> www.ginac.de Git - ginac.git/blobdiff - check/CMakeLists.txt
Remove exhashmap<T> class.
[ginac.git] / check / CMakeLists.txt
index 42fe50e1f4457eb4b8ab8bdbe037d91c9c9837ac..c229a818789e41ecc0a0acac1e2b13b246eb175b 100644 (file)
@@ -29,10 +29,10 @@ set(ginac_tests
        exam_clifford
        exam_archive
        exam_structure
-       exam_hashmap
        exam_misc
        exam_mod_gcd
        exam_cra
+       exam_real_imag
        bugme_chinrem_gcd
        factor_univariate_bug
        pgcd_relatively_prime_bug
@@ -43,7 +43,6 @@ set(ginac_timings
        time_gammaseries
        time_vandermonde
        time_toeplitz
-       time_hashmap
        time_lw_A
        time_lw_B
        time_lw_C
@@ -71,7 +70,7 @@ macro(add_ginac_test thename)
                set(${thename}_sources ${thename}.cpp ${${thename}_extra_src})
        endif()
        add_executable(${thename} EXCLUDE_FROM_ALL ${${thename}_sources})
-       target_link_libraries(${thename} ginac)
+       target_link_libraries(${thename} ginac ${LIBDL_LIBRARIES})
        add_dependencies(check ${thename})
        add_test(NAME ${thename} COMMAND ${thename}${CMAKE_EXECUTABLE_SUFFIX})
 endmacro()