]> www.ginac.de Git - ginac.git/blobdiff - check/CMakeLists.txt
Change www.ginac.de urls to https.
[ginac.git] / check / CMakeLists.txt
index 0445a4a10f2a336bfabd0dcafa8f5ba0cd687bad..c229a818789e41ecc0a0acac1e2b13b246eb175b 100644 (file)
@@ -6,6 +6,7 @@ set(ginac_tests
        check_inifcns
        check_matrices
        check_lsolve
+       check_mul_info
        heur_gcd_bug
        exam_paranoia
        exam_heur_gcd
@@ -28,10 +29,10 @@ set(ginac_tests
        exam_clifford
        exam_archive
        exam_structure
-       exam_hashmap
        exam_misc
        exam_mod_gcd
        exam_cra
+       exam_real_imag
        bugme_chinrem_gcd
        factor_univariate_bug
        pgcd_relatively_prime_bug
@@ -42,7 +43,6 @@ set(ginac_timings
        time_gammaseries
        time_vandermonde
        time_toeplitz
-       time_hashmap
        time_lw_A
        time_lw_B
        time_lw_C
@@ -70,7 +70,7 @@ macro(add_ginac_test thename)
                set(${thename}_sources ${thename}.cpp ${${thename}_extra_src})
        endif()
        add_executable(${thename} EXCLUDE_FROM_ALL ${${thename}_sources})
-       target_link_libraries(${thename} ginac)
+       target_link_libraries(${thename} ginac ${LIBDL_LIBRARIES})
        add_dependencies(check ${thename})
        add_test(NAME ${thename} COMMAND ${thename}${CMAKE_EXECUTABLE_SUFFIX})
 endmacro()