]> www.ginac.de Git - ginac.git/blobdiff - check/CMakeLists.txt
Clean up check suite a little bit.
[ginac.git] / check / CMakeLists.txt
index 42fe50e1f4457eb4b8ab8bdbe037d91c9c9837ac..bd6b76049540efac9837dccec8c203c871a0b001 100644 (file)
@@ -6,7 +6,6 @@ set(ginac_tests
        check_inifcns
        check_matrices
        check_lsolve
-       check_mul_info
        heur_gcd_bug
        exam_paranoia
        exam_heur_gcd
@@ -19,6 +18,7 @@ set(ginac_tests
        exam_inifcns_nstdsums
        exam_differentiation
        exam_polygcd
+       exam_collect_common_factors
        exam_normalization
        exam_factor
        exam_pseries
@@ -29,12 +29,11 @@ set(ginac_tests
        exam_clifford
        exam_archive
        exam_structure
-       exam_hashmap
        exam_misc
        exam_mod_gcd
        exam_cra
+       exam_real_imag
        bugme_chinrem_gcd
-       factor_univariate_bug
        pgcd_relatively_prime_bug
        pgcd_infinite_loop)
 
@@ -43,7 +42,6 @@ set(ginac_timings
        time_gammaseries
        time_vandermonde
        time_toeplitz
-       time_hashmap
        time_lw_A
        time_lw_B
        time_lw_C
@@ -71,7 +69,7 @@ macro(add_ginac_test thename)
                set(${thename}_sources ${thename}.cpp ${${thename}_extra_src})
        endif()
        add_executable(${thename} EXCLUDE_FROM_ALL ${${thename}_sources})
-       target_link_libraries(${thename} ginac)
+       target_link_libraries(${thename} ginac ${LIBDL_LIBRARIES})
        add_dependencies(check ${thename})
        add_test(NAME ${thename} COMMAND ${thename}${CMAKE_EXECUTABLE_SUFFIX})
 endmacro()