]> www.ginac.de Git - ginac.git/blobdiff - check/CMakeLists.txt
Clarify types of test suite files.
[ginac.git] / check / CMakeLists.txt
index 0243617cb97710ff640645ef5904c252e469924b..9ef3a709c8f27edbb0116413f7b31baf65adbd51 100644 (file)
@@ -1,24 +1,19 @@
-include_directories(${CMAKE_CURRENT_SOURCE_DIR}/../ginac)
-add_definitions(-DIN_GINAC)
 
-set(ginac_tests
-       check_numeric
-       check_inifcns
-       check_matrices
-       check_lsolve
-       heur_gcd_bug
+set(ginac_exams
        exam_paranoia
        exam_heur_gcd
-       match_bug
-       parser_bugs
-       exam_numeric_archive
+       exam_match
+       exam_parser
        exam_numeric
        exam_powerlaws
        exam_inifcns
        exam_inifcns_nstdsums
+       exam_inifcns_elliptic
        exam_differentiation
        exam_polygcd
+       exam_collect_common_factors
        exam_normalization
+       exam_sqrfree
        exam_factor
        exam_pseries
        exam_matrices
@@ -28,20 +23,24 @@ set(ginac_tests
        exam_clifford
        exam_archive
        exam_structure
-       exam_hashmap
        exam_misc
+       exam_pgcd
        exam_mod_gcd
-       exam_cra
-       bugme_chinrem_gcd
-       pgcd_relatively_prime_bug
-       pgcd_infinite_loop)
+       exam_real_imag
+       exam_chinrem_gcd)
+
+set(ginac_checks
+       check_numeric
+       check_inifcns
+       check_matrices
+       check_lsolve
+       check_cra)
 
 set(ginac_timings
        time_dennyfliegner
        time_gammaseries
        time_vandermonde
        time_toeplitz
-       time_hashmap
        time_lw_A
        time_lw_B
        time_lw_C
@@ -69,23 +68,27 @@ macro(add_ginac_test thename)
                set(${thename}_sources ${thename}.cpp ${${thename}_extra_src})
        endif()
        add_executable(${thename} EXCLUDE_FROM_ALL ${${thename}_sources})
-       target_link_libraries(${thename} ginac)
+       target_link_libraries(${thename} ginac::ginac)
+       add_dependencies(test_suite ${thename})
        add_dependencies(check ${thename})
-       add_test(NAME ${thename} COMMAND ${thename}${CMAKE_EXECUTABLE_SUFFIX})
+       add_test(NAME ${thename} COMMAND $<TARGET_FILE:${thename}>)
 endmacro()
 
 macro(add_ginac_timing thename)
        set(${thename}_extra_src timer.cpp randomize_serials.cpp)
        add_ginac_test(${thename})
+       target_compile_definitions(${thename} PRIVATE HAVE_CONFIG_H)
 endmacro()
 
 set(check_matrices_extra_src genex.cpp)
 set(check_lsolve_extra_src genex.cpp)
-set(exam_heur_gcd_sources heur_gcd_bug.cpp)
-set(exam_numeric_archive_sources numeric_archive.cpp)
 
-foreach(tst ${ginac_tests})
-       add_ginac_test(${tst})
+foreach(exm ${ginac_exams})
+       add_ginac_test(${exm})
+endforeach()
+
+foreach(chk ${ginac_checks})
+       add_ginac_test(${chk})
 endforeach()
 
 foreach(tmr ${ginac_timings})