]> www.ginac.de Git - ginac.git/blobdiff - check/CMakeLists.txt
build: CMake: made it easier to run tests in parallel
[ginac.git] / check / CMakeLists.txt
index 9c38932c4a06f73a1f94ede3f60571551c9dbda9..544c412e976f202f8abbb098a8231d447a95986f 100644 (file)
@@ -71,6 +71,7 @@ macro(add_ginac_test thename)
        endif()
        add_executable(${thename} EXCLUDE_FROM_ALL ${${thename}_sources})
        target_link_libraries(${thename} ginac ${LIBDL_LIBRARIES})
+       add_dependencies(test_suite ${thename})
        add_dependencies(check ${thename})
        add_test(NAME ${thename} COMMAND $<TARGET_FILE:${thename}>)
 endmacro()