* INSTALL: reflect Cint status.
[ginac.git] / INSTALL
diff --git a/INSTALL b/INSTALL
index 584801e3410afc68fd6b3a655242084f13d54e67..fadf8baeef4837b4e781ed156ec82f9d06c70c76 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -29,7 +29,7 @@ As with any autoconfiguring GNU software, installation is as easy as this:
  $ make
  $ make check
 [become root if necessary]
$ make install
# make install
 
 Known to work with:
   - Linux/x86, EGCS-1.1.x and GCC 2-95.x
@@ -71,12 +71,11 @@ COMMON PROBLEMS
 Problems with CLN
 -----------------
 
-You should use at least CLN V1.0.3, since during the development of
+You should use at least CLN-1.1, since during the development of
 GiNaC various bugs have been discovered and fixed in earlier versions.
-To protect you, the "configure" script checks for a feature that was
-added in V1.0.3 so it won't continue with earlier versions anyhow.
 Please install CLN properly on your system before continuing with
-GiNaC.
+GiNaC.  When using GCC3 as compiler please use at least CLN-1.1.1
+since some parts of GiNaC won't build with CLN-1.1.
 
 Problems with building ginsh
 ----------------------------
@@ -111,7 +110,5 @@ to compile, install and work properly:
  Cint version | how it works
 --------------+----------------------------------------------------------
  < 5.14.39    | `VERBOTEN' by license (please bite your favorite lawyer)
- < 5.14.39,40 | compiles but does not feel happy at all (inconsistent!)
-   5.14.41    | tested on egcs 1.1.1, gcc 2.95.2: some weirdnesses
-   5.14.44    | does not compile: G__cpp_ginaccint.C needs manual fixes
-   5.14.45    | compiles fine, still some weirdnesses during execution
+ < 5.14.60    | since GiNaC version 0.7, these do not compile any more
+   5.14.62-79 | compiles fine, works well with GCC 2.95.x.  GCC3 no go.